top of page

Forumbeiträge

lvisintini
17. Apr. 2022
In Einsteigerfragen + FAQ
I think that the software should aim, as much as possible, to serve the UI from http://openscanpi (or whatever the Rpi's IP is) without having to use the :1880 port or the "/ui" path. The http server should really be listening for requests on port 80. That way there is no need for the address to have an explicit port to work. I understand that the software is currently in development but this particular thing makes it difficult for beginners to start making use of the hardware they spent time and money putting together. The Node-Red admin (or whatever that is) is referenced by the FAQ as being only for experts and curious people, so it really makes no sense for it be the thing that appears on the page when using typing http://openscanpi:1880 in the browser's address bar. The UI should be served from that address or at least that address should redirect to the UI
0
2
76
lvisintini
17. Apr. 2022
In Software
Hi there, I'm having issues getting a preview images on the UI's Scan page. My current setup is an OpenScan Mini with Rpi Camera v2. The current software version is 2022-01-05-10.56 (the latest at the time of this writing) All the hardware setup is correct and the configuration for the camera is also fine. The setting "Preview On/Off" is currently set to "On" in the settings and my expectation is that, once the scan routine is running, that the preview image would periodically be automatically refreshed with the latest picture taken by the hardware. However, my experience is that the preview is only updated every time I refresh the page. I have tried clearing the browser cache but it has not produced different results. I have restarted the hardware but the problem persists. I have not attempted any Node-Red changes to remedy the situation because I am really out of my depth when it comes to that particular spaghetti. Is there an expectation that anyone making use of this project would have to learn (or know) what Node-Red is and how to leverage it to make full use of the hardware? Aside from that bug, I also have a feature request.... I was surprised to see that there is no button that could be used to get the preview updated "on demand" for initial testing and calibration purposes. (to check the lights and position of the model) It seems to me that the only way to get a preview image is by starting the scan program whilst having "Preview On/Off" set to "On" and that to me is very poor user experience. I have guys experienced the same problem with this latest software update? Cheers, Luis
1
2
145

lvisintini

Weitere Optionen
bottom of page